Game On: Feature Requests & Bug Reports Part II

Posted on Aug 30, 2016 by Mike Skocko Latest activity: Apr 2, 2017

29 1,352
  • 5 1 Rating

Archived conversation (1100+ comments): Feature Requests & Bug Reports (Part I)


My students write the code that makes this project possible. If you have an idea—even a blue sky idea—for this iteration of Game On, this is the place to share it. If you find a bug or something that just doesn't feel right, this is the place to report it.

We maintain a list of these items on our Dev Team Page page. Please check to see if your idea/issue is already on our radar.

Our best ideas come from our users. Don't be shy about giving the kids a challenge.


Game On Downloads If you're using quest chains, use 2.5.6. Otherwise, 2.5.9 is solid. The v3 Pre-Release is NOT ready for prime time—test sites only are recommended.

Comments (29)

Forest Hoffman

Posted on Apr 2, 2017 12:40:13 AM - Permalink

​I'm going to link this adjacent discussion on ​​​exporting quests, because it fulfills one of our long desired features.

Matthew Miller

Posted on Mar 12, 2017 6:32:25 AM - Permalink

​Ran into some potentially undesirable interactions between roll-back behaviors and expired quests: I use timed quests for quizzes, such that rewards expire 85 minutes after the quest is opened. When players open the quests after that, it quite properly reports that they are unable to gain additional rewards as the time has expired.


​This round, I had one player who didn't complete the mastery stage properly, so I rolled his quest back and asked him to complete it according to the instructions. My plan was to award him the credits manually, using the Clipboard, once he'd done his work properly. However, he misunderstood and tried to use the "Undo" button to roll back. He found the quest removed the award amount, as expected, but he couldn't then regain the reward (of course, and as expected). He continued to try for a couple more cycles, dropping his XP and Gold substantially in the process, as quizzes are worth a tidy bundle. The Stats panel and Clipboard reflect this negative effect, showing -750XP and -450Gold for that quest.

​Now, partially this is just poor user behavior. But maybe we could do something about it on the code side, too, with a warning when players try to undo a quest that is expired? Also, it looks like the loot summary at the top of the quest only shows "Expired" for the Complete stage, rather than all stages (though I haven't tested all scenarios of this, yet Edit: confirmed: only the Complete stage shows Expired, including if there are 5 stages).

Forest Hoffman

Posted on Mar 12, 2017 6:56:32 PM - Permalink

Okay, i've made an ​iss​ue for this. This is a quality-of-life issue, so it'll be scheduled for v3.1.0. Thanks Matthew!

Richard Van Eck

Posted on Jan 14, 2017 5:48:01 PM - Permalink

I installed GameOn 2.6.2 and created 6-7 quests with upload and test options and a quest chain. I added 12 users and we were all using the site successfully for about a day. Suddenly, I can no longer login to the admin panel for my wordpress site. When I disable all plugins (by renaming the plugin file folder as suggested by WP Beginners Guide) I am able to login. When I enable ONLY the GameOn plugin, I IMMEDIATELY cannot login to the admin panel.

I do not want to lose my work and am unsure how to fix this problem. Can I reinstall Game On? If I do, will it retain all my original settings? Should I roll back to an earlier version? Need help quickly--my class is halted and the students need to make progress on quests this week! Any help is appreciated...

Mike Skocko

Posted on Jan 14, 2017 6:17:12 PM - Permalink

??!

This is a new one, Richard. One answer I'm sure of, you'll not lose quests or data by deactivating, deleting, and reinstalling Game On. (That's how we all update or roll back.)

Who is your host?

In a worst case scenario, I can host a site for you via a Media Temple GRID Pro server.

Ryan Hayes

Posted on Dec 8, 2016 6:53:29 PM - Permalink

​How are you guys handling embedding videos in your missions? I know that Mike has switched to embedding directly into Wordpress, but I really like the display video plugin because it allowed me to control the size of the video. An embedded video is too small, full screen on OSX takes over the whole screen, etc. Watching a video on YouTube is often too small and again if you go full screen it takes over the whole screen.With the 27 inch iMacs there is plenty of room to have a tutorial video side by side with the application the students are working in.

However, both Safari and Chrome are now disabling flash bey default. The Game ON display video plugin relies on flash and it keeps chasing headaches.

So, just wondering what everybody has decided on.

Mike Skocko

Posted on Dec 8, 2016 7:59:07 PM - Permalink

I've been digging Divi's Video Slider Module in ​the 411 each day (daily updates) — ​EXA​MPLE — but I've been timid about trying to use the Divi Builder in quests (custom post types). One day...​ Until then, the embed option works gloriously for me.

As for an in-between size for side by side viewing with the app, just hit Command + with the browser active to increase the size of the video incrementally. Yes?

Matthew Miller

Posted on Oct 17, 2016 8:34:06 PM - Permalink

​Help! I've got something bugged in the database for GO. When I disable the plug-in, my site works (as far as it can, without GO). When I enable the plug-in I can log in as an admin, but user accounts receive a 504 Gateway Timeout error attempting to log in. With the plug-in deactivated, log in as user is no problem. I can't find anything in the phperrorlog and don't know where else I might look to figure this out.

Forest and Mike, I've emailed you login credentials if you want to get in to test it. [Mike - this is a reflex action; I'm expecting I'll probably need Forest's expertise on this one, when he can spare the time.]

Mike Skocko

Posted on Oct 17, 2016 9:16:03 PM - Permalink

The only suggestion I have at this point is to roll back to 2.5.9 and give it another go (just to eliminate the possibility it's a 2.6.0 issue). ​

2.5.9 is solid.

Matthew Miller

Posted on Oct 18, 2016 5:28:51 AM - Permalink

2.5.9 didn't change the login problem, but then it occurred to me to create a new account to test with and that one had no problems logging in at all. Deleting and recreating my demostudent accounts allowed them to log in. So I'll check with students this morning to see if any of them are having trouble. It may be a false alarm, just having been a corrupted demostudent account. Keeping my fingers crossed until class. :-)​

Forest Hoffman

Posted on Oct 18, 2016 5:55:31 AM - Permalink

That would explain why I was suddenly able to log into the student accounts! Let me know if the problem persists for any other users.

Mike Skocko

Posted on Oct 18, 2016 11:06:41 AM - Permalink

The only time I remember a 504/Game On error ​was in conjunction with Quest Pods. That, too, corrupted user accounts, didn't it?

Anyway, here's hoping it was just a transient gremlin.

Matthew Miller

Posted on Oct 18, 2016 7:09:57 PM - Permalink

Whew! Looks like it was just the two demo accounts that had corruption. I had my entire class in and busy this afternoon with nary a complaint about access. (Mike, yes the 504 was related to account corruption caused by the Quest Pods issue - scary and no fun.)

So, no further problems with access at the moment. I may have corrupted those accounts somehow while I was testing and troubleshooting another issue I've run into. Divi gurus, here is a puzzler: I have the most recent update installed. On my class newsletter, The Daily, I've run into really bizzare behavior. The page loads just fine, but certain Divi modules and elements are being ignored. For example, the "Job assignments, alerts and challenges" is formatted on the back end as a price list with one of the 3 highlighted (I change it each block, so the current class is highlighted as they arrive). On the front end, though, we just see a blah html sequence of paragraphs; though the other css formatting (color, size, links, etc) has come through OK. You can see what it's supposed to look like (mostly - it's squished by the sidebar) at http://nolatlabs.com/category/the-daily.

I have a similar problem with http://nolatlabs.com/lobby/lobby/, which was much like Mike's front page in that it had a post slider with images and brief text on every post. Now, it's missing all the images. Works fine otherwise.

So Divi is mostly working, but weirdly ignoring certain elements on a couple pages. They're both subpages of the /lobby, but I don't know if that's coincidence or connected somehow. I've tried everything I can think of and now have a ticket open with Elegant Themes, but if anyone here has similar experience to share, or a suggestion for something to try, I'd be grateful. Things I've already tried with no luck:

  • Rebuilt the page (it's just a single Divi container, single row, single module (Blog), selecting posts tagged "The Daily").
  • Rebuild the post from scratch, typing in all the items and selecting the photos by hand.
  • Removed all theme customization from style.css
  • Swapped to the factory Divi theme, in case something in my child theme was causing this
  • Turned off all plug-ins
  • Switched to a different page template ("Blank Page" instead of "Default Template")
  • Set the WP_MEMORY_LIMIT and WP_MAX_MEMORY_LIMIT both to 128MB.

I'm running Wordpress 4.6.1 with php version 5.6.26, mysql version 5.6.29, and the apache mod_rewrite module turned on.

Mike Skocko

Posted on Oct 20, 2016 2:48:27 PM - Permalink

Glad that the former problem was indeed transient (though I wonder how the two new accounts became corrupted).

As for the Divi weirdness, I don't know what to say. I'm running the latest Divi/WordPress builds and am experiencing no problems. My jump to 3.0, however, was in response to the video slider suddenly failing to work. (I use them on ​the weekly 411 pages.) I'd not updated anything other than content so the glitch made no sense to me. Perhaps Divi 3.1 will remedy your issue. (It's supposedly coming very soon.)

Matthew Miller

Posted on Oct 21, 2016 8:48:17 AM - Permalink

Update on this: after a week of trading (slow) posts on the Divi support forums and finally having to get rather shirty with the support folks, I finally got confirmation that it's a bug and has been escalated to the developers. Here's what happened:

Over at nolatlabs.com, my daily post for the kids was confusing to them initially (they were not distinguishing between posts in the whole feed. So I simplified it by building a single page with one blog module showing only the most recent post tagged The-Daily. Nothing else.

When I updated to Divi 3.0.14 last Sunday, that page suddenly didn't display the post properly. Only bits in the main text box of modules was displayed; other modules, like price tables, images, headings, etc. didn't display at all.

I traded posts with support technicians at ET all week, straining my patience as I responded to stuff like "Wordpress requires php version 5.0 or higher, are you running that?" I finally lost my temper after a sequence in which the tech tried to tell me that the blog module wasn't supposed to show the full content of a post (despite the checkbox in the module settings that has "excerpt" and "full content" as options).

I have developed a suspicion that the techs there are rated on how many seconds they spend on any one ticket--or perhaps their pay is related directly to how many tickets they process in a time period--so they have high incentive to respond quickly and move on, resulting in knee jerk responses that are really unhelpful.

But it finally occurred to me yesterday to check gnimmargorp, too. I was able to create the same combination of complicated post + single-page-w-blog-module and the problem did not occur. I checked Divi and found I was running 3.0.9 still. I snapped a screenshot and then updated to Divi 3.0.15 and TaDa! Instant problem. Screenshot that one, too.

That pair of screenshots finally convinced the support guy that there really was a problem. He escalated it to the developers right then. In the meantime, he provided a copy of Divi 3.0.9 and I've downgraded to that version until a fix is released. Yay!

Takeaway: always download a copy of the Divi theme for roll-back in case the most recent update has problems. (Something I really appreciate about GameOn is that all the prior versions are available so roll-back is very easy. Better service than many commercial products, like Divi!)

Mike Skocko

Posted on Oct 21, 2016 6:50:36 PM - Permalink

Awesome persistence, Bulldog! Er, Matthew. :)

Great Advice re: Divi backups.

As for us and the revisions, thank Rob Schwartz for that. For the longest time we just kept overwriting the master. Rob pointed out versioning a long time ago in a post far, far away and the rest is history.


Side note: v2.6.1 gives us new superpowers. v2.6.2 will fix a small glitch in updating the progress bar color live via stores items.​ Thank Forest for the former and Anthony (new coder!) for the latter.

I'll record a video explaining the nuances this weekend.

Mike Skocko

Posted on Oct 21, 2016 6:51:33 PM - Permalink

What the fragnog is up with EdEx formatting?!​

Mike Skocko

Posted on Oct 11, 2016 7:02:27 PM - Permalink

Forest Hoffman

Posted on Sep 28, 2016 3:18:42 PM - Permalink

I'm trying to confirm this bug, ​#1​29. If you're on the bleeding edge, I've made a few commits to my development branch for version v3.0.1, which can be downloaded ​h​ere.

I've created new quests with test data on Chrome, Firefox, and Safari, with admin and student accounts, without seeing the bug. Is anyone else experiencing this bug (with the updated dev version)?

Mike Skocko

Posted on Oct 2, 2016 5:02:59 PM - Permalink

Worked for me. Tested Chains, too. They seemed to work as well (for students).

Matthew Miller

Posted on Sep 4, 2016 2:21:56 PM - Permalink

Thank goodness! I should have thought of that a few hundred posts ago...I've been cursing the slowness for a while. D'oh!

Also, I don't know if this is a bug or a feature, but I discovered that the Badges board on the status window and the badges count in the Clipboard aren't using the same reference, or formula, or something. Here's what happened:

Some of my players decided to ignore the warnings and buy themselves a slew of XP buffs in the store. They're now working off Damage. I went into the database and removed the unauthorized store purchases, adjusted their XP total to reflect the actual quests they'd completed, then adjusted their rank and badges to reflect reality as well. Their stats board now reads correctly, but the clipboard still shows the number of badges they'd had listed for the inflated XP total.

Mike Skocko

Posted on Sep 4, 2016 2:42:26 PM - Permalink

Laughing at the here's what happened. I, too, have some knuckleheads and I resorted to creating Reaper's Reward just for them (costs 100 Gold, 100 XP, and 2 Damage to boot). The kids who are paying attention crack up when I go into game show host voice and say, Tell him what he's won!

As for the clipboard oddness, that's a job for Forest (though I have a returning coder who's almost ready for something like this).

Forest Hoffman

Posted on Sep 7, 2016 10:30:26 PM - Permalink

That definitely counts as weird. Noted, thank you!

Forest Hoffman

Posted on Sep 16, 2016 8:04:07 PM - Permalink

Hmm, what version are you using?

Forest Hoffman

Posted on Sep 25, 2016 4:56:18 PM - Permalink

> Hmm, what version are you using?

Matthew, the reason I ask is, I wasn't able to recreate the issue on v3.0.1 (the hotfix version on my development branch). The clipboard and stats page pull from the same table (`*go_totals`). If there's a mismatch, it may be that the serialized array of badges in the users' `*usermeta` table still contains the original number of elements (despite them being empty). That would make the stats page report more badges than the number reported on the clipboard.

So, I'm wondering if this is an issue that may have been dealt with, accidentally, in v3.0.0.

EDIT: Edited to make more sense.

Matthew Miller

Posted on Sep 25, 2016 5:46:16 PM - Permalink

Sorry, Forest. I must have missed the original post. I am using 2.6.0 and looking into the back end, that appears to be exactly what happened. Nice work, fixing problems we hadn't even reported yet!

Because I just had to look it up and it occurred to me, here's a small, very-non-essential feature request: it'd be useful if the standard Wordpress "At a glance" widget on the Dashboard reported the current version of Game-On as well as the Wordpress version and the theme.

Forest Hoffman

Posted on Sep 25, 2016 6:05:34 PM - Permalink

​No worries!

> reported the current version of Game-On as well as the Wordpress version and the theme

I can certainly look into that in a later release. I'd like that quality of life addition as well. The At a Glance widget may be locked down, but that would be an interesting thing to try out.
That may fit into an existing request involving a dynamic version number (​#120).

Mike Skocko

Posted on Aug 30, 2016 3:45:02 PM - Permalink

The old page was loading so slowly I couldn't bear it anymore. I won't lock that page until everyone has moved over to this thread.

Forest Hoffman

Posted on Aug 31, 2016 2:37:32 PM - Permalink

Great choice.